Специалист 1С
Хотите сократить затраты на сопровождение 1С? Переходите на безлимит - детально по тел. (985) 230-78-55
Решаем любые вопросы по 1С быстро и без проблем!

Работа со строками

Операции со строками

Как проверить, что переменная является строкой?

Сравнить тип переменной с типом «Строка»

Пример:

Если ТипЗнч(НашаПеременная) = Тип("Строка") Тогда
   Сообщить("Переменная строкового типа!");
КонецЕсли;

Как узнать длину переменной строкового типа?

Функцией глобального контекста СтрДлина()

Пример:
СтрДлина(«Привет мир!») – вернет число 11

Как убрать пробелы в начале/конце строки?

Использовать функции глобального контекста СокрЛ(), СокрП(), СокрЛП()

СокрЛ(НашаСтрока) – убрать пробелы из указанной строки слева

СокрП(НашаСтрока) – убрать пробелы из указанной строки справа

СокрЛП(НашаСтрока) – убрать пробелы с обеих сторон

Как проверить, что строка пустая/не пустая?

Использовать функцию глобального контекста ПустаяСтрока()

Пример:

Если ПустаяСтрока(НашаПеременная) Тогда
   Сообщить("Строка абсолютно пуста!");
КонецЕсли;

Примечание: также можно использовать универсальную функцию ЗначениеЗаполнено(). Разница заключается в том, что данная функция предназначена для проверки на пустоту значений любых типов, а ПустаяСтрока() только строк.

Пример:

Если ЗначениеЗаполнено(НашаПеременная) Тогда
   Сообщить("Строка не пуста!");
КонецЕсли;

Как узнать, входит ли в строку определенная подстрока?

Воспользоваться функцией глобального контекста Найти()

Пример:
Найти(«Арифмометр», «метр») – вернет число 7 (возвращается позиция первого найденного знака искомой подстроки)

Примечание: при указании искомой подстроки имеет значение регистр символов,  поэтому например
Найти(«Арифмометр», «Метр») – вернет 0

Как заменить строку или часть строки на другую?

С помощью функции глобального контекста СтрЗаменить()

Пример:
СтрЗаменить(«Перестрелка», «стрелка», «стройка») – вернет строку «Перестройка»

Предыдущие записи рубрики

работа с датами в 1с Работа с датами

Как явно указать нужную дату? 1) Литералом встроенного языка вида ‘ГГГГММДДччммсс’ ; '20101103160457' - вернет значение 03.11.2010 16:04:57 '2011.05.09:11:00:05' - получим 09.05.2011 11:00:05 или так: '2009/12/02' - вернет значение 02.12.2009 0:00:00 2) Функцией глобального контекста Дата(); Дата(2008, 06, 4, 18,45,...

хитрости платформы Использование конфигурации поставщика

В данной статье я хочу показать сервисные возможности платформы 1С:Предприятие 8, в части использования конфигурации поставщика, которые очень часто бывают востребованы, но как показала практика, знакомы отнюдь не всем начинающим и даже опытным специалистам. Рассмотрим...

Варианты работы информационных баз 1С Варианты работы информационных баз 1С:Предприятие 8

Файловый режим Архитектура: Все данные хранятся в одном файле специализированного формата 1cv8.1CD Ограничения: Размер таблиц ИБ < 4Gb Количество пользователей критично Неразделяемые табличные блокировки Регламентные задания только в пользовательском сеансе Невозможность...