Специалист 1С
Хотите сократить затраты на сопровождение 1С? Переходите на безлимит - детально по тел. (985) 230-78-55
Решаем любые вопросы по 1С быстро и без проблем!

Работа с датами

Как явно указать нужную дату?

1) Литералом встроенного языка вида ‘ГГГГММДДччммсс’ ;

'20101103160457' - вернет значение 03.11.2010 16:04:57
'2011.05.09:11:00:05' - получим 09.05.2011 11:00:05

или так:

'2009/12/02' - вернет значение 02.12.2009 0:00:00

2) Функцией глобального контекста Дата();

Дата(2008, 06, 4, 18,45, 23) - вернет значение 04.06.2008 18:45:23
Дата(2011, 2, 16) - вернет значение 16.02.2011 0:00:00

3) Если нам необходимо в тексте запроса указать конкретную дату — тогда используем литерал ДАТАВРЕМЯ().

|    ДАТАВРЕМЯ(2004, 10, 04)

Как проверить дату на пустое значение?

1) Сравнить его со значением по умолчанию: начало первого дня первого месяца первого года:

Если ПроверяемаяДата = '00010101' Тогда
	Сообщить("Пустая дата!");
КонецЕсли;

или

Если ПроверяемаяДата = Дата(1,1,1) Тогда
	Сообщить("Пустая дата!");
КонецЕсли;

2) Использовать функцию глобального контекста ЗначениеЗаполнено()

ЗначениеЗаполнено('2011.05.09') - вернет Истина
ЗначениеЗаполнено('00010101') - вернет Ложь

 

Как сравнить две даты (дни)?

Если сравнить необходимо именно дни — то нужно предварительно воспользоваться функцией, которая возвращает, например, дату начала или конца дня, а потом уже сравнивать полученные значения, т.к. точность данных типа Дата — до секунды.

Если КонецДня(ПерваяДата) = КонецДня(ВтораяДата) Тогда
	Сообщить("Дни совпадают!"); 
КонецЕсли;

Как прибавить к дате день, месяц?

Тип Дата содержит дату и время с точностью до секунды, поэтому чтобы к некоторой дате прибавить один день, нужно увеличить ее значение на количество секунд, содержащихся в одном дне:

СледующийДень = ТекущаяДата() + 60 * 60 * 24;

Для увеличения или уменьшения даты можно использовать: 1) функции работы со значением типа Дата во встроенном языке;

ДобавитьМесяц('20091231', 1) - вернет значение 31.01.2010 0:00:00	
НачалоМесяца(ДобавитьМесяц(Дата(2011, 2, 21), -1)) - вернет 01.01.2011 0:00:00

2) функции работы со значением типа Дата в запросах.

	| ДОБАВИТЬКДАТЕ(&ИсходнаяДата, ДЕНЬ, &Количество) КАК НоваяДата")

Предыдущие записи рубрики

хитрости платформы Использование конфигурации поставщика

В данной статье я хочу показать сервисные возможности платформы 1С:Предприятие 8, в части использования конфигурации поставщика, которые очень часто бывают востребованы, но как показала практика, знакомы отнюдь не всем начинающим и даже опытным специалистам. Рассмотрим...

Варианты работы информационных баз 1С Варианты работы информационных баз 1С:Предприятие 8

Файловый режим Архитектура: Все данные хранятся в одном файле специализированного формата 1cv8.1CD Ограничения: Размер таблиц ИБ < 4Gb Количество пользователей критично Неразделяемые табличные блокировки Регламентные задания только в пользовательском сеансе Невозможность...

встроенный язык 1с Встроенный язык 1С:Предприятие 8

Если вы уже знакомы с каким-либо языком программирования, например Basic или Pascal, вы можете заметить много общего со встроенным языком 1С:Предприятие. Тем не менее, у встроенного языка 1С есть на мой взгляд ряд преимуществ, которые я перечислю далее. 1. Поддержка...